BlueAnt Wireless

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Blackberry Z30 | Trouble Connecting

Gerry Shuster — Oct 27, 2014 04:00AM AEDT

I have an S4, a Blackberry Z30 with current firmware, and a Blackberry Torch 9810.

While the S4 worked fine with the Blackberry 9810 Torch, I am having trouble with the Blackberry Z30.

When I turn on the S4, it finds the Z30, connects, and then seems to turn itself off even though the switch is still on; the S4 responds to nothing, either voice command or touch. I need to turn the switch to off, then back to on, often several times until a connection is finally established and maintained.

If I connect to my Blackberry 9810 Torch I do not have this problem.

What is the issue with the Z30, and can you help please?


3 Community Answers

Alan - Oct 27, 2014 at 12:37PM AEDT BlueAnt Wireless Agent

Thank you for your enquiry Gerry,

In order for us to provide you with the best solution, please follow the steps below and provide us with additional information regarding your Blackberry device.

1. On your Z30, delete all pairing information from the Bluetooth’s paired list and turn the phone completely OFF.
2. Reset your S4 by holding down both the volume PLUS and MINUS symbols for 10 seconds. Device needs to be ON and not connected to any other phones.
3. Turn the Blackberry back ON and then pair it back to the S4.

Once you have done this, please give it a test run to see if it helps. If the same issue continues to occur, please provide us with the following details.

• What is the software version installed on your Z30?
• What network provider are you with?
• When this issue occurs, are any of the lights flashing on the S4?
• Have you tested the Z30 with other Bluetooth devices to see if you can replicate the same issue?
• Have you checked to see if your phone have any available updates?

Thank you.


rated : 0 Up Down

Gerry Shuster - Oct 28, 2014 at 12:37AM AEDT

Resetting per instruction seems to have rectified the problem.

thank you!


rated : 0 Up Down

Alan - Oct 28, 2014 at 03:35PM AEDT BlueAnt Wireless Agent

Not a problem Gerry.

We’re glad you got it working again.


rated : 0 Up Down

Post Your Public Answer